Aktuelles
Die DFN-Mitteilungen Nr. 95 sind erschienen
NHR geht an den Start
Karriere beim DFN
DFN-Infobrief Recht Ausgabe Juni 2019 erschienen
Leistungssteigerung ermöglicht Nutzercommunity High Speed Netzanbindung von bis zu 200 Gbit/s

Installationshinweise

Allgemeines

Dieses Dokument soll eine Hilfestellung für die Konfiguration des GRE-Tunnels für den DFNSAPdirekt-Dienst geben. Als Beispiel wurde eine Konfiguration für Cisco-Router benutzt. Für Router anderer Hersteller kann anhand dieses Beispiels eventuell eine Konfiguration abgeleitet werden.

Inbetriebnahme

Schritt 1 - Auftrag zur Realisierung von DFN-SAPdirekt ausfüllen und zusenden

In diesem Dokument sind die notwendigen vertraglichen und technischen Informationen vorhanden, die zur Realisierung benötigt werden. Das Dokument kann von der DFN-Geschäftstelle Berlin (030/884299-0) angefordert werden.
Auftrag zur Realisierung von DFN-SAPdirekt

Bitte senden Sie das Dokument ausgefüllt an DFN-Verein, z. H. Holger Wirtz, Alexanderplatz 1, 10178 Berlin.

Schritt 2 - Konfiguration des Tunnels

Auf Anwenderseite kann nun die Konfiguration des Tunnels erfolgen. Dieses Beispiel orientiert sich an der vom DFN-NOC in den FAQs empfohlenen Konfiguration des WAN-Interfaces zum X-WiN mittels einer Loopback-Adresse.
FAQ des DFN-NOC

interface Tunnel0
description Tunnel zum DFN-SAPdirekt-Diens
ip unnumbered Loopback 0
tunnel source Loopback 0
tunnel destination 195.37.234.49
ip classless
ip route 194.45.237.64 255.255.255.224 Tunnel0 ;ggf. für Fehlersuche notwendig
ip route 147.204.2.0 255.255.255.0 Tunnel0 ;Netze, in denen sich die
SAP-Router von SAP befinden.
ip route 194.117.106.0 255.255.255.240 Tunnel0

Sollten Sie eine Konfiguration ohne Loopback-Interface haben, können Sie auch den Bezeichner des Interfaces direkt einsetzen (in diesem Fall POS1/0):

interface Tunnel0
description Tunnel zum DFN-SAPdirekt-Dienst
ip unnumbered POS1/0
tunnel source POS1/0
tunnel destination 195.37.234.49
ip classless
ip route 194.45.237.64 255.255.255.224 Tunnel0 ;ggf. für Fehlersuche notwendig
ip route 147.204.2.0 255.255.255.0 Tunnel0 ;Netze, in denen sich die
SAP-Router von SAP befinden.
ip route 194.117.106.0 255.255.255.240 Tunnel0

Schritt 3 - Rückmeldung vom DFN-Verein und Text

Nach Eingang des Auftrags wird auf dem DFN-Router bei SAP (tr-sap.dfn.de) der Tunnelendpunkt konfiguriert und eine Anmeldung der Einrichtung bei SAP vorgenommen.

Wenn der Tunnel auf beiden Seiten konfiguriert ist, kann der erste Test erfolgen:

ping 194.45.237.92

Ein ping auf das LAN-Interface des tr-sap.dfn.de sollte erfolgreich sein. Als weiteren Test sollte ein traceroute nach dem Tunnelendpunkt an der Einrichtung nur noch einen weiteren HOP zeigen (alle HOPs durch das X-WiN sind durch den Tunnel "maskiert"):

traceroute 194.45.237.92
1 zpl-gw.dfn.de (192.76.176.1) 1 ms 0 ms 0 ms
2 195.37.234.49 (195.37.234.49) 17 ms * 20 ms

Wenn beides der Fall ist, ist der Tunnel beidseitig richtig konfiguriert.

Sobald SAP die Anmeldung vorgenommen hat wird die nutzende Einrichtung benachrichtigt und ein Test, ob der SAP-Router erreichbar ist, kann erfolgen. Ab diesem Zeitpunkt muß ein ping auf die IP-Adresse des SAP-Routers (147.204.2.5) bei SAP erfolgreich sein.

Ist dieser Test auch erfolgreich, ist die Tunnelanbindung vorhanden und die SAP-Applikationen sollten für weitere Tests der höheren Schichten benutzt werden.

Troubleshooting

Falls Probleme mit dem Verbindungsaufbau von SAP zum SAP-Router der jeweiligen Einrichtung auf Port 3299 auftreten sollten, obwohl der Tunnel einwandfrei funktioniert (Verbindungsaufbau von der Einrichtung zu SAP möglich), liegt hierbei vermutlich ein Problem mit einem Verfahren, dass DoS (Denial of Service) unterdrücken soll, vor. Näheres (für Cisco-Router) dazu unter Cisco auf den Web-Seiten (s. u.). Dieses Feature sollte für die Adressen von SAP deaktiviert werden.

Kontakt

Falls Sie Fagen oder Probleme zur technischen Realisierung haben, so wenden Sie Sich bitte an: hostmaster@dfn.de.

     aktualisiert am: 07.09.2015 |